Tag Archives: qmail

Plesk and “qq trouble in home directory”

After upgrading Plesk from an old, but working, 8.6.0 to a recent version everything worked fine afterwards. Then I did the “mistake” and enabled the build-in greylisting feature. Out of sudden I wasn’t able to send a mail anymore. I got a “qq trouble in home directory” error message.

Hmm … Bad!. Ok. First I checked the permissions of the qmail installation. All fine. So I searched around. A lot of people out there are having the same problem. It’s the greylisting feature! Plesk qmail thinks we are an extern sender and routes even local domains through the greylist. Bump!

So you may think: “A lot of people are having the same problem, so there is a quick solution!”. Nope – There isn’t! It take some a lot of hours to find a solution by myself. At all it’s easy – if you know how 🙂

So what to do? Since Plesk Version 9.0 you can choose your MTA between qmail and postfix. However the postfix implementation is causing more problems then the qmail one. So I still use qmail. Via the autoinstaller script of Plesk you can easily switch between these two MTAs. And that’s was the solution of my qmail “qq trouble in home directory” problem.
Start the autoinstaller /usr/local/psa/admin/bin/autoinstaller. On the component list choose Postfix mailserver and continue. The script will uninstall the qmail mailserver and install the postfix mailserver. All current mails will keep in place. So don’t worry (however a backup is always and every time a good idea :-)). The completion of the script takes several minutes. After that do the same thing but select Qmail mailserver. For me it worked fine and the “qq trouble in home directory” error was gone.

Quick ToDo:

  • Start /usr/local/psa/admin/bin/autoinstaller
  • Select Postfix mailserver as mailserver
  • Finish the installation
  • Start /usr/local/psa/admin/bin/autoinstaller
  • Select Qmail mailserver as mailserver
  • Finish the installation
  • Done